Mainos

Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

Arkisto phpBB2 versiosta.
Tuki tälle versiolle on loppunut 1.1.2009
Alueen säännöt
phpBB2 tuki on loppunut 1.1.2009

Alkuperäinen tiedote phpbb.comista löytyy tämän linkin takaa.
http://www.phpbb.com/community/viewtopi ... &t=1385785

Nämä alueet on jätetty toistaiseksi näkyville Arkistona.
phpBB2 ongelmia ei tule kirjoittaa phpBB3 alueelle, Ainoa tuettu toimenpide phpBB2:en on konvertoiminen phpBB3 versioon. :)

Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja r_u_o_t_0 » 21 Marras 2008, 22:57

Ymmärsin näiltä sivuilta, että jos päivitän muinaisesta phpbb-versiostani uudempaan; phpbb2.0.22 tai 2.0.23-versioon, kopioimalla päälle muuttuneet failit, niin olen pulassa, jos minulla onkin MOD:eja asennettuna. En siis ole kuin en olekaan itse foorumia kasannut, ja kontaktit kasanneisiin on kadonneet ajan virtaan. Kysyn siis:

Kaatuuko koko hökötys, jos vaan reippaasti kopioin muuttuneet failit päälle, ja MOD:eja hautautuu alle?

Minua ei haittaa jos mahdolliset MOD:it lakkaavat toimimasta, ainoa tavoitteeni on saada foorumin sisältö konvertointikelpoiseksi phpbb3:a varten. Ja sitten kohti kolmosta..

Itse en suosittelisi itseäni vielä tässä vaiheessa lähellekään koodin muokkaamista..
r_u_o_t_0
Aloittelija
Aloittelija
 
Viestit: 6
Liittynyt: 21 Marras 2008, 21:44

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja mrl586 » 22 Marras 2008, 00:29

Mikä nykyinen phpBB:n versio on?
mrl586
Aktiivinen jäsen
Aktiivinen jäsen
 
Viestit: 2883
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja r_u_o_t_0 » 22 Marras 2008, 13:35

foorumini/docs/README otsikoi: phpBB 2.0.13

Muu dokumentaatio on sopusoinnussa sen kanssa. Mikä sinänsä on jo helpotus...
r_u_o_t_0
Aloittelija
Aloittelija
 
Viestit: 6
Liittynyt: 21 Marras 2008, 21:44

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja Lurttinen » 24 Marras 2008, 11:07

Jos tavoite on vain konvertointi, niin siihen riittää pelkkä tietokannan päivitys.
Eli otat päivityspaketista sen /install -hakemiston ja sieltä ajat sen tietokannan päivityksen.

Sen jälkeen asennat kolmosen ja konvertoit vanhan. Kakkosen tiedostoja ei tarvita, kuin ne hymiöt ja avatarit. Foorumin muilla tiedostoilla ei ole juurikaan väliä. :)

Tietty, jos kakkosessa on asennettuna eri kieliä, niin nuo kannattaa asentaa kolmoseenkin ennen konvertointia. :)
BTC: 12uZ4tXHfjm5ByKkgvQbByYx3K6pE1yier
LTC: Lbx3egsK1ubD2SgYmnBaxmJJb1xzaoPBhd

phpBB Suomi Facebookissa.
Avatar
Lurttinen
phpBB nub
phpBB nub
 
Viestit: 5144
Liittynyt: 13 Marras 2005, 19:41
Paikkakunta: Tampere

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja r_u_o_t_0 » 25 Marras 2008, 09:24

Ällistyttävän hyviä uutisia, että tuollainen oikopolku löytyy!!! Tuhannet kiitokset neuvosta, nyt tuli niin toiveikas mieli, että lähdenpä ensiksi hyppimään lätäkköihin hetkeksi. SSploshhh',';
r_u_o_t_0
Aloittelija
Aloittelija
 
Viestit: 6
Liittynyt: 21 Marras 2008, 21:44

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja r_u_o_t_0 » 27 Marras 2008, 13:03

Pieni huoli vielä, kun polskuttelin selaimellani sinne install-hakemistoon tekemän sitä update_to_latest-juttua, eli konvertoimaan tietokantaa ensin versiosta 2.0.13 versioon 2.0.23, niin tuli näkyviin raportti, jossa kaiken oli kirjattu onnistuneen loistavasti, lukuunottamatta yhtä erroria. Errorissa napistiin, että "updating version and optimizing tables"-vaiheessa joitain ajoja ei oltu voitu suorittaa menestyksellä, sillä "matalamutalahti.SESSIONS_KEYS_TABLE"-taulua ei ole olemassa.
Lisätiedoksi oli kirjattu: SQL :: DELETE FROM SESSIONS_KEYS_TABLE

Jos raportti tarkoittaa, että tuon taulun deletointi ei onnistunut koska sitä ei ollut olemassakaan, niin ei liene syytä huoleen? Eihän?? :? Konvertointi kuitenkin sujui loppuun asti.

:)
r_u_o_t_0
Aloittelija
Aloittelija
 
Viestit: 6
Liittynyt: 21 Marras 2008, 21:44

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja Lurttinen » 27 Marras 2008, 15:11

Sessions_keys pitäs olla olemassa.
Aja se update_to_latest uudelleen. Jos ei futaa, niin tuossa query jolla sen voisi luoda. Huomaa, että prefix on tuossa esimerkissä "phpbb_" joten vaihda se jos sulla on eri.
Prefixin voi tarkistaa config.php tiedostosta. :)

Koodi: Valitse kaikki
CREATE TABLE `phpbb_sessions_keys` (
  `key_id` varchar(32) NOT NULL default '0',
  `user_id` mediumint(8) NOT NULL default '0',
  `last_ip` varchar(8) NOT NULL default '0',
  `last_login` int(11) NOT NULL default '0',
  PRIMARY KEY  (`key_id`,`user_id`),
  KEY `last_login` (`last_login`)
) TYPE=MyISAM;
BTC: 12uZ4tXHfjm5ByKkgvQbByYx3K6pE1yier
LTC: Lbx3egsK1ubD2SgYmnBaxmJJb1xzaoPBhd

phpBB Suomi Facebookissa.
Avatar
Lurttinen
phpBB nub
phpBB nub
 
Viestit: 5144
Liittynyt: 13 Marras 2005, 19:41
Paikkakunta: Tampere

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja r_u_o_t_0 » 28 Marras 2008, 01:43

:lol: Olisi ollut niin mukavaa ajelehtia laiskana, automaattisesti soljuvan asennuksen mukana, ja vain kellua uhkaavien karikkojen ohi...

Kiitos, Lurttinen! Ryhdistäydyin, ja tarkistin tilanteen. Tiedän, että alunperin minulla ei ollut kyseistä tietokantataulua ollenkaan, siinä phpbb2.0.13-versiossani. Mutta nyt, siinä versioon 2.0.23 sopivaksi "välikonvertoidussa" tietokannassa on tuo taulu, ja se on joka kentän osalta identtinen antamasi queryn kanssa.

Ja kun nyt olen sitten edelleen konvertoinut foorumin tietokannan phpbb3.0.3-versioon sopivaksi, tuo samainen taulu, tosin eri etuliittellä nimettynä, on hieman erilainen. Siinä oli viimeksi käytetyn IP-osoitteen syötekenttään laitettu tilaa 40 merkille 11 sijaan, ja utf8_bin tullut latin_swedish:in tilalle, mutta muuten taulun rakennehan oli edelleen sama.

Että eiköhän tässä olla jo aika selvillä vesillä tältäerää?!?! :) Kiitos!!
r_u_o_t_0
Aloittelija
Aloittelija
 
Viestit: 6
Liittynyt: 21 Marras 2008, 21:44

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja Lurttinen » 28 Marras 2008, 08:43

r_u_o_t_0 kirjoitti: Että eiköhän tässä olla jo aika selvillä vesillä tältäerää?!?! :) Kiitos!!

O-oouu...
Rupesit manaamaan...
BTC: 12uZ4tXHfjm5ByKkgvQbByYx3K6pE1yier
LTC: Lbx3egsK1ubD2SgYmnBaxmJJb1xzaoPBhd

phpBB Suomi Facebookissa.
Avatar
Lurttinen
phpBB nub
phpBB nub
 
Viestit: 5144
Liittynyt: 13 Marras 2005, 19:41
Paikkakunta: Tampere

Re: Pitäisi päivittää - mutta jos minulla onkin MOD:eja!!!

ViestiKirjoittaja r_u_o_t_0 » 28 Marras 2008, 19:47

PULP!!! Totta, tuo kaipaa määritelmän, tai olemme tuhon omat.

Sana "tältäerää" on kaikenlaiseen kompuutoimiseen liittyvä, hetkellistä huojennusta, pienen yksityiskohdan osalta, toistaiseksi, ehkä, ilmaiseva, toivomuslauseen täsmennyssana.

:lol: :lol: :lol: Jos säät ovat suotuisat, pulahdan seuraavaksi pintaan phpBB3:n puolella.
r_u_o_t_0
Aloittelija
Aloittelija
 
Viestit: 6
Liittynyt: 21 Marras 2008, 21:44


Paluu phpBB2 tuki / Tuki loppunut 1.1.2009

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 1 vierailijaa

Mainos

cron