Ongelmia anti bot question -modin asentamisessa

MODien asennus ja omat muokkaukset.
Avatar
Silja
MODaaja
MODaaja
Viestit: 55
Liittynyt: 26 Heinä 2006, 19:38
Viesti:

Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja Silja » 24 Helmi 2008, 12:01

Taas vaihteenvuoksi säheltäjä yritti asentaa modia eikä ylläri ylläri onnistunut. Kyseessä on siis tämä modi.

Mikä ei siis onnistunut? Ilmeisesti ei mikään. Foorumi toimii kyllä suomen kielellä ihan normaalisti, mutta ei tuolla ACP:ssä mitään Anti bot question -valikkoa ole. Lisäksi englanninkielisessä versiossa on jotain häikkää, heittää tällaista virheilmoitusta:

Koodi: Valitse kaikki

Warning: Cannot modify header information - headers already sent by (output started at /home/pt4642/public_html/foorumi/language/lang_english/lang_main.php:1) in /home/pt4642/public_html/foorumi/includes/page_header.php on line 483

Warning: Cannot modify header information - headers already sent by (output started at /home/pt4642/public_html/foorumi/language/lang_english/lang_main.php:1) in /home/pt4642/public_html/foorumi/includes/page_header.php on line 485

Warning: Cannot modify header information - headers already sent by (output started at /home/pt4642/public_html/foorumi/language/lang_english/lang_main.php:1) in /home/pt4642/public_html/foorumi/includes/page_header.php on line 486
Englanninkielisellä versiolla en pääse hallintapaneliin ollenkaan, antaa tällaisen virheilmoituksen:

Koodi: Valitse kaikki

Warning: Cannot modify header information - headers already sent by (output started at /home/pt4642/public_html/foorumi/language/lang_english/lang_main.php:1) in /home/pt4642/public_html/foorumi/admin/index.php on line 647

Warning: Cannot modify header information - headers already sent by (output started at /home/pt4642/public_html/foorumi/language/lang_english/lang_main.php:1) in /home/pt4642/public_html/foorumi/admin/index.php on line 648
Mitäs pitäis tehdä?

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja Lurttinen » 24 Helmi 2008, 12:17

Sulla on jossain noissa tiedostoissa ylimääräistä joko ennen <?php riviä tai lopussa olevan ?> jälkeen.
siellä ei saa olla ennen/jälkeen yhtään mitään. Ei edes välilöyntiä tai rivinvaihtoa.

Avatar
Silja
MODaaja
MODaaja
Viestit: 55
Liittynyt: 26 Heinä 2006, 19:38
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja Silja » 25 Helmi 2008, 22:28

Siis tuossa lang_main.php -tiedostossa vai missä tahansa modiin liittyvässä (php?) tiedostossa?

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja mrl586 » 25 Helmi 2008, 22:37

Silja kirjoitti:Siis tuossa lang_main.php -tiedostossa vai missä tahansa modiin liittyvässä (php?) tiedostossa?
lang_main.php-tiedostossa...

Avatar
Silja
MODaaja
MODaaja
Viestit: 55
Liittynyt: 26 Heinä 2006, 19:38
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja Silja » 02 Touko 2008, 10:10

Näin reippaana tyttönä tartuin näin heti parin kuukauden sisällä toimeen asian korjaamiseksi. :D
Lurttinen kirjoitti:Sulla on jossain noissa tiedostoissa ylimääräistä joko ennen <?php riviä tai lopussa olevan ?> jälkeen.
siellä ei saa olla ennen/jälkeen yhtään mitään. Ei edes välilöyntiä tai rivinvaihtoa.
Möö. Ei ollu, eikä futaa vieläkään...

Nyt tosin on vaihtunut tuo herja, joka tulee kun yrittää hallintapaneliin sisälle:

Koodi: Valitse kaikki

Warning: Cannot modify header information - headers already sent by (output started at /home/pt4642/public_html/foorumi/language/lang_english/lang_main.php:1) in /home/pt4642/public_html/foorumi/includes/functions.php on line 960

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja mrl586 » 02 Touko 2008, 17:30

Välilyöntejä tai rivinvaihtoja väärissä paikoissa?

Avatar
Silja
MODaaja
MODaaja
Viestit: 55
Liittynyt: 26 Heinä 2006, 19:38
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja Silja » 03 Touko 2008, 10:05

mrl586 kirjoitti:Välilyöntejä tai rivinvaihtoja väärissä paikoissa?
Varmaan on, mutta kun osais vielä etsiä, että missä... :oops: Alussa ennen <?php:tä ei ole eikä lopussa ?>:n jälkeen. Missä muissa kohdissa nuo kämmit mahdollisesti vois olla (jos tällaista nyt sitten voi edes lähteä arvailemaan ilman tuon tiedoston näkemistä...)?

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja Lurttinen » 03 Touko 2008, 10:12

Aloita näistä kahdesta

foorumi/language/lang_english/lang_main.php
foorumi/includes/functions.php

Avatar
Silja
MODaaja
MODaaja
Viestit: 55
Liittynyt: 26 Heinä 2006, 19:38
Viesti:

Re: Ongelmia anti bot question -modin asentamisessa

Viesti Kirjoittaja Silja » 13 Touko 2008, 21:08

Olen noita kahta tiedostoa nyt tässä syynäillyt enkä kyllä keksi mitenkään, että missä vika voisi olla. Täytynee vissiin sitten unohtaa koko modin asennus ja toivoa, ettei kukaan käytä englanninkielistä versiota foorumista...

Viestiketju Lukittu

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Google [Bot] ja 5 vierailijaa