3.09 -> 3.10 päivitys / FI kieliongelma

phpBB3 ongelmia. Neuvoja ja ohjeita kuinka korjata.
MOD kysymykset, niiden asennukset ja omien muokkausten ongelmat alempana olevalle MOD alueelle.
mahalla
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 14
Liittynyt: 28 Tammi 2012, 05:17

3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja mahalla » 28 Tammi 2012, 05:34

Latasin pelkät päivityspaketit 3.09 -> 3.10 (+FI kielipakeketit) ja päivitys kaatui heti alkuun seuraavaan virheeseen:

Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /home/X/public_html/forum/language/fi/install.php on line 553

Parse error: syntax error, unexpected T_STRING, expecting ')' in /home/X/public_html/forum/language/fi/install.php on line 553

Päivityksen kaaduttua nimesin väliaikaisesti install -hakemiston uudelleen, jotta foorumi toimii.
Sivut toimii, mutta nyt en pääse foorumin ylläpitoon (3.09); kirjautuminen onnistuu, mutta esiin tulee tyhjä sivu???

Apuva! Miten päivityksen 3.09 -> 3.10 saa ajettua toimivaksi :?

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja Lurttinen » 28 Tammi 2012, 11:14

Siirrä tämä tiedosto uudestaan palvelimelle
language/fi/install.php

Ylläpidon valkoinen sivu saattaa olla välimuistin kiusaa.
Tyhjennä cache/ -hakemisto foorumin juuresta, mutta jätä sinne index.html ja .htaccess -tiedostot.

mahalla
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 14
Liittynyt: 28 Tammi 2012, 05:17

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja mahalla » 28 Tammi 2012, 13:06

Sain foorumin päivityksen läpi ajamalla version 3.0.10 uudet tiedostot palvelimelle, mutta yhden päivitetyn tiedoston lataaminen /forum/includes/acm/acp_forums.php ei onnistu useata ftp-latausyrityksestä huolimatta.

Tuon seurauksena (?) foorumi toimii muuten ok, mutta ykstityisviestit eivät toimi.

Avun tarve jatkuu ja kiitokset jo etukäteen.

mahalla
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 14
Liittynyt: 28 Tammi 2012, 05:17

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja mahalla » 28 Tammi 2012, 13:06

Sain foorumin päivityksen läpi ajamalla version 3.0.10 uudet tiedostot palvelimelle, mutta yhden päivitetyn tiedoston lataaminen /forum/includes/acm/acp_forums.php ei onnistu useata ftp-latausyrityksestä huolimatta.

Tuon seurauksena (?) foorumi toimii muuten ok, mutta ykstityisviestit eivät toimi.

Avun tarve jatkuu ja kiitokset jo etukäteen.

Avatar
Peetra
phpBB Bitch
phpBB Bitch
Viestit: 1169
Liittynyt: 04 Kesä 2007, 16:45
Paikkakunta: Kokkola
Viesti:

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja Peetra » 28 Tammi 2012, 14:46

Ei tunnu siltä että just toi tiedosto voisi hajottaa yv-toimintoa.

Oletko kokeillut nyt uudestaan? Uudelleenkäynnistä omaa tietokoneesi ennen sitä viimeistä yritystä.
muista backuppi!
hyvä copy/paste monen kannan dumpille: http://www.patrickpatoray.com/?Page=30 // ei tartte omaa ohjelmistoa.
hyvä ison kannan dumpeille http://www.mysqldumper.net/ //Selkeä käyttöliittymä! Asentuu palvelimelle kuin itsestään. :ugeek:

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja Lurttinen » 28 Tammi 2012, 14:51

Voit ottaa tuon acp_forums.php tiedoston suoraan phpBB 3.0.10 paketista ja siirtää palvelimelle.
Huomioi virheilmoitukset, jos sellaisen näet FTP-ohjelmassasi.

miten YV ei toimi?
Tuleeko virheilmoitusta?

mahalla
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 14
Liittynyt: 28 Tammi 2012, 05:17

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja mahalla » 28 Tammi 2012, 17:22

Sain yv:t toimimaan (siirtämällä ainoastaan 3.0.10 muuttuneet tiedostot uudelleen palvelimelle) tuloksena, että foorumi on lähes toiminnassa.
Mutta /www/forum-juuressa oleva posting.php ei suostu siirtymään aiheuttaen tietenkin sen, että viestejä ei voi kirjoittaa. Eli tuloksena oli askel eteen ja kaksi taakse :wtf:

Parse error: syntax error, unexpected $end, expecting ']' in /home/X/public_html/forum/posting.php on line 1426

Käytän Filezillaa ftp-siirrossa ja sillä tuon ongelmatiedoston siirtoa en saa onnistumaan (kaikki muut tiedostot siirty suht ok, viimeistään useamman siirtoyrityksen jälkeen).

Eli konsultaatiota tarvitaan edelleen.

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja Lurttinen » 28 Tammi 2012, 17:32

Sanooko filezilla mitään virheilmoitusta miksi ei siirry?

Voit kokeilla myös, esimerkiksi WinSCP:llä tai smartFTP:llä, josko siirtyisi paremmin.

EDIT: Koita poistaa ensin posting.php ja sen jälkeen siirrä pelkästään tämä yksi tiedosto.

mahalla
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 14
Liittynyt: 28 Tammi 2012, 05:17

Re: 3.09 -> 3.10 päivitys / FI kieliongelma

Viesti Kirjoittaja mahalla » 28 Tammi 2012, 18:52

FTP-ohjelman vaihto auttoi (-> WinSCP).
Kaikki aikaisemmatkin ongelmat ovat liittyneet vastaaviin siirtovirheisiin.
Eli kannattaa varmistaa, että phpBB:n päivitetut tiedostot menevät varmasti palvelimelle.

Kiitokset avusta!

Viestiketju Lukittu

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 15 vierailijaa