Autologin ei toimi kun foorumi sijaitsee alidomainissa?

phpBB3 ongelmia. Neuvoja ja ohjeita kuinka korjata.
MOD kysymykset, niiden asennukset ja omien muokkausten ongelmat alempana olevalle MOD alueelle.
Hermanni
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 13
Liittynyt: 08 Tammi 2009, 02:27
Paikkakunta: Mänttä
Viesti:

Autologin ei toimi kun foorumi sijaitsee alidomainissa?

Viesti Kirjoittaja Hermanni » 22 Touko 2012, 00:46

Terve.
Meillä on vähän ongelmia automaattisen kirjautumisen kanssa?
Ongelma tulee vastaan jos menee foorumille suoraan osoitteesta http://www.veturitalli.net
Autologin taas toimii jos selaimeen kirjoittaa http://www.sisulan.net/veturitalli osoitteen?
Veturitalli.net foorumi sijaitsee fyysisesti alidomainissa sisulan.net/veturitalli

Evästeiden asetukset
Evästeiden palvelin: .veturitalli.net
Evästeen nimi: veturitalli
Evästeen polku: /
Suojattu eväste: Poissa käytöstä

Palvelimen URL asetukset
Pakota url asetukset: Kyllä
Palvelimen protokolla: http://
Toimialueen nimi: sisulan.net
Palvelimen portti: 80
Ohjelman polku: /veturitalli


Osaisiko joku auttaa miten nuo asetukset pitäisi olla jotta autologin toimisi http://www.veturitalli.net osoitetta käytettäessä?
Myöskin vastausviesti sähköpostiin tulee muodossa http://www.sisulan.net/veturitalli/viewtopic.php***
Saako sen myös korjattua niin että vastausviesti sähköpostiin tulisi muodossa http://www.veturitalli.net/viewtopic.php***
http://www.veturitalli.fi Suomalainen pienoisrautatiefoorumi.

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: Autologin ei toimi kun foorumi sijaitsee alidomainissa?

Viesti Kirjoittaja Lurttinen » 22 Touko 2012, 08:54

Palvelimen url-asetukset on pakotettu menemään sisulaan, siksi myös säpossa linkki on väärin.
Saattaa vaikuttaa myös kirjautumiseen, en ole varma.

Ota pakotus pois päältä tai laita se osoittamaan veturitallia kohti.

Sen jälkeen poista sisulan ja veturitallin evästeet selaimesta -> yritä kirjautumista uudelleen.

Hermanni
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 13
Liittynyt: 08 Tammi 2009, 02:27
Paikkakunta: Mänttä
Viesti:

Re: Autologin ei toimi kun foorumi sijaitsee alidomainissa?

Viesti Kirjoittaja Hermanni » 22 Touko 2012, 23:17

Nyt on asetuksina seuraavat...

Evästeiden asetukset
Evästeiden palvelin: www.veturitalli.net
Evästeen nimi: veturitalli
Evästeen polku: /
Suojattu eväste: Poissa käytöstä

Palvelimen URL asetukset
Pakota url asetukset: Ei
Palvelimen protokolla: http://
Toimialueen nimi: www.veturitalli.net
Palvelimen portti: 80
Ohjelman polku: /

Mutta ongelma on edelleen sama, autologin ei toimi näilläkään asetuksilla.
Ja jos pakotan url asetukset päälle en pääse foorumille kirjautumisen jälkeen, luulisi että tuolla pakottamisella se autologin pitäisi nimenomaan toimia?
Onkohan jotain asetuksissa pielessä, saako tuossa evästeen palvelimessa olla tuo www alku?
http://www.veturitalli.fi Suomalainen pienoisrautatiefoorumi.

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: Autologin ei toimi kun foorumi sijaitsee alidomainissa?

Viesti Kirjoittaja Lurttinen » 23 Touko 2012, 10:39

Evästeiden palvelimessa ei saa olla www:tä alussa. Pelkkä .veturitalli.net
(Huomaa tuo piste ennen veturitallia, kuten oli myös alunperin)

Tyhjennä taas evästeet ja mene veturitalli.net ja kokeile kirjautumista.
(Sisulan osoitetta ei käytetä ollenkaan näihin kirjautumisiin. Siitä tulee taatusti ongelmaa, jos yrität kirjautua yhdelle foorumille kahden domainin kautta. Evästeet toimivat vain veturitalli.net -osoitteelle. :) )

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Re: Autologin ei toimi kun foorumi sijaitsee alidomainissa?

Viesti Kirjoittaja mrl586 » 23 Touko 2012, 11:29

Lurttinen kirjoitti:Evästeiden palvelimessa ei saa olla www:tä alussa. Pelkkä .veturitalli.net
(Huomaa tuo piste ennen veturitallia, kuten oli myös alunperin)
Väitän päinvastaista. Palvelimen nimi voidaan ilmoittaa kahdella tavalla: joko ilman subdomainta (.veturitalli.net) tai sen kanssa (http://www.veturitalli.net). Molemmat ovat siis toimivia muotoja.

Squirrel
Aloittelija
Aloittelija
Viestit: 4
Liittynyt: 18 Marras 2005, 14:46

Re: Autologin ei toimi kun foorumi sijaitsee alidomainissa?

Viesti Kirjoittaja Squirrel » 25 Marras 2012, 00:40

Miksi outo virititys, onko kyseessä webhotelli, johon liitetty vain rinnakkaisdomain? Vai onko kyseessä kotipalvelin ja ei osata konfikuroida palvelinohjelmistoa oikein?

Viestiketju Lukittu

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 13 vierailijaa