Spam/roskaposti ongelmaa?

Arkisto phpBB2 versiosta.
Tuki tälle versiolle on loppunut 1.1.2009
Alueen säännöt
phpBB2 tuki on loppunut 1.1.2009

Alkuperäinen tiedote phpbb.comista löytyy tämän linkin takaa.
http://www.phpbb.com/community/viewtopi ... &t=1385785

Nämä alueet on jätetty toistaiseksi näkyville Arkistona.
phpBB2 ongelmia ei tule kirjoittaa phpBB3 alueelle, Ainoa tuettu toimenpide phpBB2:en on konvertoiminen phpBB3 versioon. :)
Feeniks
Aloittelija
Aloittelija
Viestit: 7
Liittynyt: 26 Touko 2007, 18:32

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja Feeniks » 08 Elo 2007, 19:20

Kolmosversion kanssa en kuolemaksenikaan uskalla käydä säätämään, mutta tosiaan, sehän aukesikin Muistioon ihan järkevän näköisenä! Kiitos. (Seuraava missio: asennus... Tarvitsisin selvästikin jonkin rautalankaversion tuosta MOD-osiossa olevasta ohjeesta :shock:)

Beam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 12
Liittynyt: 09 Maalis 2007, 11:16

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja Beam » 10 Elo 2007, 22:05

Täällä on minusta selkeä ohje
http://www.marshalrusty.com/phpBB/rac.mod

Itselläni ei ole niin minkäänlaisia php-taitoja, mutta koodin asennus onnistui ongelmitta lukemalla ohjeet huolellisesti ja hitaasti ja seuraamalla niitä.

Avatar
pearl
Oppii uutta
Oppii uutta
Viestit: 36
Liittynyt: 03 Tammi 2007, 16:07

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja pearl » 18 Elo 2007, 09:39

En saanut toimimaan tätä...

etsin tiedostot ja koodeista oikeat kohdat joidenjälkeen lisäsin annetut koodit, mutta ei tule rekisteröinti ikkunaan mitään VIp code kenttää.... ?!



#-----[ OPEN ]------------------------------------------
#
includes/usercp_register.php
#
#-----[ FIND ]------------------------------------------
#
rawurlencode($website);
}
#
#-----[ AFTER, ADD ]------------------------------------------
#
// Start myVIPcode mod
if ( ($mode == 'register') && ($HTTP_POST_VARS['myVIPcode'] != '2486') )
{
message_die(GENERAL_MESSAGE, 'Sorry, but your <b>VIP code</b> is NOT correct.<br><br>You can find a valid <b>VIP code</b> on our homepage.');
}
// End myVIPcode mod
#
#-----[ FIND ]------------------------------------------
#
$template->assign_block_vars('switch_confirm', array());
}
#
#-----[ AFTER, ADD ]------------------------------------------
#
// Start myVIPcode mod
if ($mode == 'register')
{
$template->assign_block_vars('switch_myvipcode', array());
}
// End myVIPcode mod
#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/profile_add_body.tpl
#
#-----[ FIND ]------------------------------------------
#
<!-- END switch_confirm -->
#
#-----[ AFTER, ADD ]------------------------------------------
#
<!-- BEGIN switch_myvipcode -->
<tr>
<td class="row1"><span class="gen"><b>VIP code:</b> *</span><br />
<span class="gensmall">You can find a valid <b>VIP code</b> on our homepage!</span></td>
<td class="row2">
<input type="text" class="post" style="width: 200px" name="myVIPcode" size="25" maxlength="32" value="" />
</td>
</tr>
<!-- END switch_myvipcode -->
#
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------
#

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja mrl586 » 18 Elo 2007, 09:52

Oletko tyhjentänyt selaimesi välimuistin? Entä, oletko kirjautuneena sisälle forumille vai katseletko forumia vieraana?

Avatar
pearl
Oppii uutta
Oppii uutta
Viestit: 36
Liittynyt: 03 Tammi 2007, 16:07

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja pearl » 18 Elo 2007, 20:51

Välimuisti tyhjä ja sama homma olen sitten vieraana tai rekisteröityneenä...

Ei kysy VIP Koodia!?

Avatar
pearl
Oppii uutta
Oppii uutta
Viestit: 36
Liittynyt: 03 Tammi 2007, 16:07

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja pearl » 18 Elo 2007, 21:12

Tällä Hetkellä koodit näyttävät tältä:

includes/usercp_register.php :ssä

1)
rawurlencode($website);
}

// Start myVIPcode mod
if ( ($mode == 'register') && ($HTTP_POST_VARS['myVIPcode'] != '2486') )
{
message_die(GENERAL_MESSAGE, 'Sorry, but your <b>VIP code</b> is NOT correct.<br><br>You can find a valid <b>VIP code</b> on our homepage.');
}
// End myVIPcode mod

$avatar_sql = '';

...

2)
$template->assign_block_vars('switch_confirm', array());
}
// Start myVIPcode mod
if ($mode == 'register')
{
$template->assign_block_vars('switch_myvipcode', array());
}
// End myVIPcode mod
//
// Let's do an overall check for settings/versions which would prevent ...


templates/subSilver/profile_add_body.tpl :ssä

1)

<!-- END switch_confirm -->

<!-- BEGIN switch_myvipcode -->
<tr>
<td class="row1"><span class="gen"><b>VIP code:</b> *</span><br />
<span class="gensmall">You can find a valid <b>VIP code</b> on our homepage!</span></td>
<td class="row2">
<input type="text" class="post" style="width: 200px" name="myVIPcode" size="25" maxlength="32" value="" />
</td>
</tr>
<!-- END switch_myvipcode -->

. . .


Voisiko joku joka enemmän ymmärtää, vilkaista onko kaikki ok ja jollei, niin mitä pitäisi muuttaa / korjata?

-Pearl

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja Lurttinen » 18 Elo 2007, 21:44

Onko rekisteröityjällä käytössä subsilver tyyli, johon oot tuon lisännyt?
Tuo täytyy lisätä foorumin oletustyyliin, jotta se näkyy myös rekisteröityjälle. Pelkkä subsilveriin lisääminen ei vaikuta, kuin siihen subsilveriin.

Avatar
pearl
Oppii uutta
Oppii uutta
Viestit: 36
Liittynyt: 03 Tammi 2007, 16:07

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja pearl » 18 Elo 2007, 21:58

Jep muutettu kaikkiin tyyleihin. . . ja ei silti mitään :geek:

Eli käytössä ei ole subsilveriä vaan oletuksena on joku ladattu... Ja tämä muutettu ladatun templaten tiedostoon, mutta rekisteröidyttäessä ei kysy missään vaiheessa VIP Koodia!?. . .

Ongelma on se, että forumille kirjautuu lähes joka päivä joku uusi tyyppi, joka avaa keskustelun jonnekin aiheena mainostaa aikuisviihde materiaalia sisältäviä sivuja, tai ainakin linkkejen nimistä ja mainoslätinöistä päätellen... Sama nimimerkki ei jätä kuin yhden viestin ja sitten onkin jo uudet nimimerkit. . .

Nämä ovat ilmeisesti niitä Spänbotteja, joista pitäisi nyt päästä eroon!?!?.. aluksi asetukset olivat melko vapaat, mutta suoran ja sopimattoman materiaalin ilmestyttyä asetukset muutettiin niin, että kaikkialle ei voi kirjoittaa kuin admin ja muille pitää olla rekisteröitynyt. . .

Tämän jälkeen materiaali väheni ja enää saapuu näitä edellä mainittuja "mee sivulle se ja se... "

Jos jollin vinkkejä tämän suhteen niin *Kiitos vinkkejä otetaan vastaan!!!

-Pearl

Avatar
pearl
Oppii uutta
Oppii uutta
Viestit: 36
Liittynyt: 03 Tammi 2007, 16:07

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja pearl » 20 Elo 2007, 20:21

Onko olemassa jotain muuta tapaa päästä eroon tästä ongelmasta?!

- pearl

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja mrl586 » 20 Elo 2007, 20:31

pearl kirjoitti:Onko olemassa jotain muuta tapaa päästä eroon tästä ongelmasta?!
On, päivitä forumisi Olympus-aikakaudelle.

Avatar
Admin
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 721
Liittynyt: 13 Marras 2005, 15:45

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja Admin » 20 Elo 2007, 22:47

pearl kirjoitti:Onko olemassa jotain muuta tapaa päästä eroon tästä ongelmasta?!

- pearl
Tuossa tyylissä on sitten joku ongelma. Kysy tyylin tekijältä apua tai dumppaa koko tyyli?

Avatar
pearl
Oppii uutta
Oppii uutta
Viestit: 36
Liittynyt: 03 Tammi 2007, 16:07

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja pearl » 21 Elo 2007, 11:21

päivitystä varten ilmeisesti tarvitsee ladata uusi versio, joka ladataan sivustoon vanhan päälle?. . .

Säilyykö kaikki vanhat viestit ja systeemit ?

Onko Olympukseen valmiita tyylejä jossain?

Päivitys taitaa olla ainoa järkevä vaihtoehto, mutta haluaisin tutustua tyyleihin ja serlvittää, miten päivitys onnistuisi ja onko se asia josta suoriudun ü Alkaa kyllä suunnattomasti jo ärsyttämään päivittäinen roskapostin poisto foorumeilta... Tämän hetkinen tumma tyyli vain sopii hyvin nykyiseen sivustoon . .

Ad Infinitum - On nykyisen tyylin nimi, tietääkö joku vastaavaa tyyliä Olympukseen?

Kiitos taas tuhannesti!

- Pearl

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja mrl586 » 21 Elo 2007, 17:09

pearl kirjoitti:Onko Olympukseen valmiita tyylejä jossain?
Löytyisikö täältä (RELEASE-aiheet) sopivaa tyyliä?

PS. Päivitysohjeita (http://www.phpbbsuomi.com/viewtopic.php?f=25&t=1369)

Avatar
pearl
Oppii uutta
Oppii uutta
Viestit: 36
Liittynyt: 03 Tammi 2007, 16:07

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja pearl » 21 Elo 2007, 22:21

OK,

Kiitos tästä. . . kokeilen tätä viikonloppuna

Avatar
Silja
MODaaja
MODaaja
Viestit: 55
Liittynyt: 26 Heinä 2006, 19:38
Viesti:

Re: Spam/roskaposti ongelmaa?

Viesti Kirjoittaja Silja » 12 Tammi 2008, 12:23

Vip code on pitänyt erittäin hyvin rekisteröityneet spämmääjät kurissa (lue: ei yhtään rekisteröitynyttä spämmibottia vip coden asentamisen jälkeen!), mutta mutta... Minulla on tuo yksi avoin foorumi, joka on tarkoitettu sivustoni palautteenjättöpaikaksi. Eli on siis aikasta pakko sallia vieraiden viestien kirjoittaminen. Aika paljon tulee kuitenkin näitä pillerivillejen ja pornopirkkojen spämmiviestejä ja noita on sitten aika turhauttava poistaa. Käytössä on vieraiden kirjoittaminen viestien captcha-varmennus, mutta eipä tuo ole koskaan mitään auttanut. Nyt siis kyselenkin onko olemassa jotain tehokasta tapaa karsia näitä vieraiden kirjoittamien spämmiviestien määrää (viestien kirjoitusoikeus vain rekisteröityneille ei ole sopiva ratkaisu :D ), esim. juurikin tuon vip coden tyylinen ratkaisu tms.

Viestiketju Lukittu

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 15 vierailijaa