Ongelmia päivityksen suhteen

Arkisto phpBB2 versiosta.
Tuki tälle versiolle on loppunut 1.1.2009
Alueen säännöt
phpBB2 tuki on loppunut 1.1.2009

Alkuperäinen tiedote phpbb.comista löytyy tämän linkin takaa.
http://www.phpbb.com/community/viewtopi ... &t=1385785

Nämä alueet on jätetty toistaiseksi näkyville Arkistona.
phpBB2 ongelmia ei tule kirjoittaa phpBB3 alueelle, Ainoa tuettu toimenpide phpBB2:en on konvertoiminen phpBB3 versioon. :)
Squirrel
Aloittelija
Aloittelija
Viestit: 4
Liittynyt: 18 Marras 2005, 14:46

Ongelmia päivityksen suhteen

Viesti Kirjoittaja Squirrel » 18 Marras 2005, 14:49

Yritin päivittää 2.0.17 -->2.0.18 mutta se ei suostu skulaa.

Yritin:
1. Backuppia
2. Poistin kaikki vanhat tiedostot
3. Uudet tiedostot tilalle
4. Vanha config.php tilalle
5. /install/update_to_latest.php

Virheilmoitus tuli: "Please read frist install.txt" ja olen lukenut ja tavannut vaikka kuinka monta kertaa, niin mitään en ole jättänyt tekemättä / tehnyt toisin kuin siellä.

Tietokantana on PostgreSQL. Olisiko käynyt fiba, että tekijät luuli kaikkien käyttävän MySQL:a?

Avatar
Admin
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 721
Liittynyt: 13 Marras 2005, 15:45

Viesti Kirjoittaja Admin » 19 Marras 2005, 08:12

Pistit pahan. Lurttinen (DaMan) on selkeesti fiksumpi tässäkin hommassa jahka ehtii poikkeamaan, mutta kerro vielä mikä versio PostgreSQL:sta sulla on?
Äkkiä paiskaisin lonkalta että tuorein päivitys ei vaan toimi, mutta eipä vielä vannota...

Mysli on kyllä se mihin tuo phpBB kommuuni keskittyy...

Squirrel
Aloittelija
Aloittelija
Viestit: 4
Liittynyt: 18 Marras 2005, 14:46

Viesti Kirjoittaja Squirrel » 19 Marras 2005, 09:26

8.0.3 muistaakseni.

Ei ne painostu mysliin, nehän on ihan haltioissaan kun ne mainostaa, että niiden foorumi toimii melkeinpä jokaisella ilmaisella tietokantaohjelmalla.

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja Lurttinen » 20 Marras 2005, 02:45

Tuliko tuossa muuta virheilmoitusta, kuin "Please read frist install.txt"
Mun tietääkseni phpBB paketissa ei ole readme.txt tiedostoa, mutta readme.html kyllä löytyy ja update_to_latest.php saattaa siihen viitatakin, mutta se ei ole virheilmoitus.
Vaan kehoitus.

Hyvä, että laitoit tuon proseduurin, jonka mukaan päivitit.
Jos foorumilla on nyt ne .18 tiedostot, mitään virheilmoitusta ei tule ruudulle ja admin paneelikin kertoo versioksi .18
Se on sitten .18 päivitys suoritettu onnistuneesti loppuun.

Postgres8 ei välttämättä ole tuettujen listalla. 7 versio kylläkin on.
Aika vekkuleita jamppoja, kun ilmoittavat esim php:n toimivuudesta...
PHP (4.0.3 and above) with support for the database you intend to use above
...voisi päätellä, että php5 on isompi, kuin php4, mutta todellisuudessa php5 ei ole vielä virallisesti tuettu.
Vaan toi koskee vain 4 sarjaa...
Olisko sama juttu postgres8 kohdallakin?

Avatar
Admin
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 721
Liittynyt: 13 Marras 2005, 15:45

Viesti Kirjoittaja Admin » 20 Marras 2005, 03:01

phpBB.com Userguide kirjoitti:2.1: MySQL 3 and 4, PostgreSQL 7.x, MS SQL 7/2000 (inc. via ODBC)

Before proceeding with installation you should ensure you have a database available. Ask your provider for details if you are unsure whether you do or not.
Tuossa ainakin seisoo selkeesti postgreSQL 7.x

Squirrel
Aloittelija
Aloittelija
Viestit: 4
Liittynyt: 18 Marras 2005, 14:46

Viesti Kirjoittaja Squirrel » 20 Marras 2005, 09:39

No PostgreSQL 8.x tekee kaikki sama mitä 7.x sarjakin. Siitä se ei ole kiinni.
Ja en tarkalleen muista enään mitä se näytölle ilmoitti, mutta sanoi että joku tiedosto pitää lukea.

Viestiketju Lukittu

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 23 vierailijaa