ääkkösongelma

Arkisto phpBB2 versiosta.
Tuki tälle versiolle on loppunut 1.1.2009
Alueen säännöt
phpBB2 tuki on loppunut 1.1.2009

Alkuperäinen tiedote phpbb.comista löytyy tämän linkin takaa.
http://www.phpbb.com/community/viewtopi ... &t=1385785

Nämä alueet on jätetty toistaiseksi näkyville Arkistona.
phpBB2 ongelmia ei tule kirjoittaa phpBB3 alueelle, Ainoa tuettu toimenpide phpBB2:en on konvertoiminen phpBB3 versioon. :)
Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

ääkkösongelma

Viesti Kirjoittaja Argetlam » 07 Syys 2006, 22:04

en ainakaan löytänyt tälläistä eli. Foorumin kieli on vaihdettu suomeksi ja kaikki on myös suomeksi, mutta kun viestiin kirjoittaa esim "testaan tätä"
niin tilalle tulee "testaan t " eli tietoa missä vika

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja Lurttinen » 08 Syys 2006, 08:04

Mikä sulla on merkistön koodauksena tietokannassa?
Noihin jos sais vastaukset.
http://www.phpbbsuomi.com/viewtopic.php?t=28

Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 08 Syys 2006, 09:24

Lurttinen kirjoitti:Mikä sulla on merkistön koodauksena tietokannassa?
Noihin jos sais vastaukset.
http://www.phpbbsuomi.com/viewtopic.php?t=28
Pistämäpä nuo heti ku pääsen kämpille. Toivottavasti saadaan tuo ongelma ratkastua.

Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 08 Syys 2006, 12:05

Foorumin osoite:
http://simppeli.org/~argetlam/phpBB2/index.php

Käytössä oleva tyyli:
SoftGreen


Mitä MODeja on asennettuna:
Ei mitään (vielä)

phpBB:n versio:
2.0.21

PHP versio:
4.4.3

Mikä tietokanta ja sen versio:
MySQL-versio 4.0.27-standard-log

Palveluntarjoaja:
Simppeli.org

Onko tämä asennettu itse?:
juu

Onko tämä päivitys, mistä/mihin:
ei

Onko tämä foorumi konversio jostain toisesta foorumista:
ei

Onko olemassa testitunnuksia, jos halutaan tulla kokeilemaan:
on. Tunnus: testi /passu: testi

Vikakuvaus ja TÄYDELLISET virheilmoitukset:
kieli vaihdettu suomeksi, mutta ä ja ö-kirjaimet eivät näy ja kaikki mitä ä/ö kirjaimen jälkeen kirjoittaa ei myöskään näy.

Avatar
Admin
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 721
Liittynyt: 13 Marras 2005, 15:45

Viesti Kirjoittaja Admin » 08 Syys 2006, 12:20


Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 08 Syys 2006, 12:29

ööh. tota noin kyllä tuo toimii, nyt näkyy ääkköset viesteissä. Mutta valikoiden tekstit esim "käyttäjätiedot" ovat nyt "k?ytt?j?tiedot"

jokin mättää vielä

tws
Aloittelija
Aloittelija
Viestit: 8
Liittynyt: 29 Elo 2006, 14:24

Viesti Kirjoittaja tws » 08 Syys 2006, 13:04

Tuli vain mieleen, tarkista foorumin lähdekoodista, että charset headerissa on oikea. Pitäis olla charset=iso-8859-1.

Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 08 Syys 2006, 13:12

näkyy olevan, mutta silti kyssäreitä ääkköset

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja mrl586 » 08 Syys 2006, 14:52

Mitä merkistökoodausta selaimesi käyttää?

Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 08 Syys 2006, 17:15

mrl586 kirjoitti:Mitä merkistökoodausta selaimesi käyttää?
iso-8859-1

ei hyödytä mitää jos laittaa utf-8

sauli.lepola
MODaaja
MODaaja
Viestit: 217
Liittynyt: 31 Elo 2006, 14:41
Paikkakunta: Nokia
Viesti:

Viesti Kirjoittaja sauli.lepola » 08 Syys 2006, 18:02

Joissain tapauksissa tuo lukusuunnan valinta aiheuttaa ongelmia, jos se on "normaali" vasemmalta oikealle (=left to right = ltr), niin kuin sinulla.

Koodi: Valitse kaikki

<html dir="ltr">
kannattaa koittaa vaikuttaako tuon poisto.

Löytyy themen overall_header.tpl tiedostosta

Koodi: Valitse kaikki

<html>
Tietysti pitää säilyttää. :lol:

*EDIT*
niin siis siellä tiedotossahan se on kai muodossa

Koodi: Valitse kaikki

<html dir="{S_CONTENT_DIRECTION}">
WordPress + phpBB = Creating code communities is poetry

Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 08 Syys 2006, 21:58

ja tuo tiedosto on?

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja mrl586 » 09 Syys 2006, 00:09

Argetlam kirjoitti:ja tuo tiedosto on?
overall_header.tpl

Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 09 Syys 2006, 00:40

voihan (en sano mikä) menee vaikeaksi vieläki hukkaa vaa ääkköset :? voiskoha vika olla MySQL tietokannan asetuksissa?

sauli.lepola
MODaaja
MODaaja
Viestit: 217
Liittynyt: 31 Elo 2006, 14:41
Paikkakunta: Nokia
Viesti:

Viesti Kirjoittaja sauli.lepola » 09 Syys 2006, 02:38

Argetlam kirjoitti:voihan (en sano mikä) menee vaikeaksi vieläki hukkaa vaa ääkköset :? voiskoha vika olla MySQL tietokannan asetuksissa?
Tuskin, testaa foorumia subSilver ulkoasulla niin nähdään onko virhe foorumisi muokatussa ulkoasussa.
WordPress + phpBB = Creating code communities is poetry

Viestiketju Lukittu

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 14 vierailijaa