ääkkösongelma

Arkisto phpBB2 versiosta.
Tuki tälle versiolle on loppunut 1.1.2009
Alueen säännöt
phpBB2 tuki on loppunut 1.1.2009

Alkuperäinen tiedote phpbb.comista löytyy tämän linkin takaa.
http://www.phpbb.com/community/viewtopi ... &t=1385785

Nämä alueet on jätetty toistaiseksi näkyville Arkistona.
phpBB2 ongelmia ei tule kirjoittaa phpBB3 alueelle, Ainoa tuettu toimenpide phpBB2:en on konvertoiminen phpBB3 versioon. :)
Argetlam
Hyvässä vauhdissa
Hyvässä vauhdissa
Viestit: 10
Liittynyt: 07 Syys 2006, 21:56

Viesti Kirjoittaja Argetlam » 12 Syys 2006, 20:08

sauli.lepola kirjoitti:
Argetlam kirjoitti:voihan (en sano mikä) menee vaikeaksi vieläki hukkaa vaa ääkköset :? voiskoha vika olla MySQL tietokannan asetuksissa?
Tuskin, testaa foorumia subSilver ulkoasulla niin nähdään onko virhe foorumisi muokatussa ulkoasussa.
ei sekää mitää auttanu :( mikähä ihme siinä sitte mättää :D

Spiderbait
MODaaja
MODaaja
Viestit: 85
Liittynyt: 24 Syys 2006, 21:22

Viesti Kirjoittaja Spiderbait » 02 Loka 2006, 16:20

Itsellä ihan sama ongelma.

Foorumin osoite: http://80.222.50.138:8080/phpbb/
Käytössä oleva tyyli:Oletus (oliko subsilver)
Mitä MODeja on asennettuna: Ei mitään
phpBB:n versio: 2.0.18-2 (Debian)
PHP versio: PHP/5.1.2
Mikä tietokanta ja sen versio: MySQL - 5.0.22
Palveluntarjoaja: Sonera (palvelin omalla serverillä)
Onko tämä asennettu itse?: Kyllä
Onko tämä päivitys, mistä/mihin: Ei
Onko tämä foorumi konversio jostain toisesta foorumista: Ei
Onko olemassa testitunnuksia, jos halutaan tulla kokeilemaan: käyttis: testi salasana: testi

Ääkköset näkyy leipätekstissä väärin, forumin valikot näkyy oikein. Olen kokeillut UTF-8 mutta sillon taas valikot näkyy väärin ja leipäteksti oikein.

Anubis
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 865
Liittynyt: 15 Elo 2006, 11:01

Viesti Kirjoittaja Anubis » 02 Loka 2006, 16:27

Ootko kokeillut kannassa latin-9 merkistöä?

Spiderbait
MODaaja
MODaaja
Viestit: 85
Liittynyt: 24 Syys 2006, 21:22

Viesti Kirjoittaja Spiderbait » 02 Loka 2006, 16:30

kokeillaan -->

ei vaikutusta :(

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja mrl586 » 02 Loka 2006, 16:31

Spiderbait kirjoitti:Käytössä oleva tyyli:Oletus (oliko subsilver)
Joo, subsilver on oletustyyli.

mrl586
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 2879
Liittynyt: 31 Maalis 2006, 17:59
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja mrl586 » 02 Loka 2006, 16:33

testasitko kannassa jo latin-1 -merkistöä?

Anubis
Aktiivinen jäsen
Aktiivinen jäsen
Viestit: 865
Liittynyt: 15 Elo 2006, 11:01

Viesti Kirjoittaja Anubis » 02 Loka 2006, 16:35

Spiderbait kirjoitti:kokeillaan -->

ei vaikutusta :(
Ihan hyvin toimii?

http://80.222.50.138:8080/phpbb/viewtop ... 372e28f#20

Se merkitstön muutoshan ei muuta niitä aikaisempia vaan vaikuttaa siitä eteenpäin.

Spiderbait
MODaaja
MODaaja
Viestit: 85
Liittynyt: 24 Syys 2006, 21:22

Viesti Kirjoittaja Spiderbait » 02 Loka 2006, 16:36

ahaa, kiitos todella paljon :)

Nyt kyllä hypin kattoon :D

perkele
Aloittelija
Aloittelija
Viestit: 2
Liittynyt: 04 Marras 2006, 18:12

Viesti Kirjoittaja perkele » 04 Marras 2006, 18:20

Ääkkösten kanssa ongelmia on. Oon kokeillu kaikkea mitä näiltä foorumeilta löysin aiheeseen liittyvää, mutta ei toimi. Äät ja ööt näkyy jos vaihdan selaimesta koodausta, mutta muuttuu takaisin ? merkeiksi heti seuraavalla refresh painauksella tai sivuilla siirtymisessä. Oon myös kokeillu sivuja toisella selaimella ja jopa toiselta koneelta.

Kiitos etukäteen.


Foorumin osoite:
http://www.keepers.ws/karhu

Käytössä oleva tyyli:
SubSilver

Mitä MODeja on asennettuna:
Ei mitään

phpBB:n versio:
2.0.21

PHP versio:
4.3.11

Mikä tietokanta ja sen versio:
MySQL, 4.1.21-standard

Palveluntarjoaja:
Futuron

Onko tämä asennettu itse?:
Fantasticon kautta

Onko tämä päivitys, mistä/mihin:
Ei

Onko tämä foorumi konversio jostain toisesta foorumista:
Ei

Onko olemassa testitunnuksia, jos halutaan tulla kokeilemaan:
testi // testi

EDIT:
Itseasiassa oon myös kokeillu php-nukea ja siinä aivan sama homma.

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja Lurttinen » 05 Marras 2006, 02:11

Lataa phpbb.comista uusi suomalainen kielipaketti ja siirrä se palvelimelle ylikirjoittean vanhat suomlaaiset tiedostot.

perkele
Aloittelija
Aloittelija
Viestit: 2
Liittynyt: 04 Marras 2006, 18:12

Viesti Kirjoittaja perkele » 05 Marras 2006, 03:02

Taisin tuonkin kokeilla, mutta testaan vielä...

Avatar
Lurttinen
phpBB nub
phpBB nub
Viestit: 4787
Liittynyt: 13 Marras 2005, 18:41
Paikkakunta: Tampere
Viesti:

Viesti Kirjoittaja Lurttinen » 05 Marras 2006, 12:13

Tuossa katselin, että tietokannassa on tuskin tuo vika sillä kirjoitetuissa viesteissä nuo ääkköset näkyy,
Huomasin, että joku pakottaa tuon sivun utf-8, vaikk oikea olisi iso-8859-1

Tarkista vielä, etä kielipaketissa on siellä alkupäässä

Koodi: Valitse kaikki

$lang['ENCODING'] = 'iso-8859-1';
Ja jos tuo on jo siellä...

Sullahan on toi foorumi vielä alkutekijöissään? Et ole kerennyt asentelemaan mitään MODeja ja sellasta?

Vaihdetaan nuo fantasticon asentamat tiedostot virallisiin phpBB2 tiedostoihin.

Eli, lataa puhdas paketti phpbb.comista. (Full package)
Pura se paketti, ja poista sen sisältä /install ja /contrib hakemistot ja se tyhjä config.php tiedosto.

Sen jälkeen mene FTP:llä palvelimelle ja kopioi foorumin hakemistosta config.php tiedosto turvaan omalle koneellesi.
ÄLÄ HUKKAA tätä tiedostoa tai ylikirjoita palvelimella olevaa missään vaiheessa.

Sen jäkeen siirrä koneeltasi ne purkamasi tiedostot palvelimelle ylirjoittaen KAIKKI tiedostot, jotka se haluaa korvata.

Viestiketju Lukittu

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 4 vierailijaa